Hi All,

I have a decimal precision issue that is causing me grief.  I'm using Sage 100 with a third party add-on for multi-currency.  In the AR_TransactionPaymentHistory table there is a numeric field for the currency exchange entry rate.  This field typically has a lot of decimal places.  When included in any container, SI is rounding the number of decimal places. 

An example is .0379550 is returned by SI as .038.  This is happening with all values for this field.  I've tried changing the data types, but no luck.  Any suggestions would be appreciated.

Thanks in advance

Karl

Views: 208

Reply to This

Replies to This Discussion

Hi Karl.

Where do you see the rounding happening, in the source data pulled via the connector or in Excel?  I just want to make sure that it's not Excel that's doing the rounding...

Hi Peter,

Its happening in the source container, prior to going to Excel. 

Karl

Any suggestions?

Hi Karl.

What add-in are you using for this? Can you please provide an image of the base amount in 100 and show how it's pulling through in the Connector. I'm not familiar with any decimal type fields in 100 so it's difficult for me to test.  Also I assume you went through all the possible data types?

You can email me directly if you want.

Hi Ken, 

Can you please tell us what the third party add-in is and give us a sample of the source code? 

Thank you, Sandra.

Sandra,

I don't know what you mean by a sample of the source code but I can provide you with a screen shot of the data in SQL and then the data that the container is returning.  It should be very clear that SI is returning a rounded number.  See screenshots below.

Has anybody ever seen this before?

Attachments:

Hi Karl.  I've replied to you directly via email.

RSS

The Sage Intelligence Blog

Like Sage Intelligence?

Follow @SageSupport

© 2019   Created by Sage Alchemex.   Powered by

Badges  |  Report an Issue  |  Terms of Service