I am getting an error message "Unable to get the Add Property of the Workbooks class" when running reports now. The last thing I had changed in Excel was page setting on the some tabs. I successfully created and link the sheet but now I can not run the report. It was running prior to these formatting changes.

 

The cursor was not on a tab nor do I have any other versions of Excel were open. (Excel 2010). I can unlink the template but I feel that I have to start over. Does anyone haver any suggesstions.

Views: 1581

Attachments:

Reply to This

Replies to This Discussion

Hi Michael -- did you ever find a resolution to this?  I have a report I created and tested on a backup of my customer's data and it ran fine and then after installing on their system they are getting this error.

Helped me!

So I spoke too soon yesterday. It seems that the fix fixes the issue and the report runs the first time. If you run it the second time, it gives you same error.

I am having this same error. the fix file did not work.  How did you solve your issue?

Still no resolution found.

Having a similar problem when running a report on a client workstation (that runs fine on my office workstation):

Hangs at the “Creating Excel Workbook” stage:

  • Each time is gives the Visual Basic Application error - “Errors occurred during load”
  • Followed by the "Unable to get Add Property of the Workbook Class" error

Tried installing the brand new exported report right after successfully running it on my machine with their data – same errors

Tried running the report from the sample company (Bellwether) data file – same errors

Tried running the “fix templates” program – same errors

Tried removing ALL the macros – same errors

My Windows version - Win 10 Home build 15063.674

Clients Windows version – Win 10 Pro build 16299.125

My Excel build version - 2016 MSO (16.0.7127.1026) 32-bit

Clients Excel build version – 2016 MSO (16.0.8730.2046) 32-bit

Has anyone found a solution to this? I am having the same issue. It seems to be located only to the templates that have macros in them. Other reports work fine. 

I have tried the "Fix templates tool" and reinstalled Excel+Sage Intelligence. Nothing has fixed the error.

Are there any other solutions available?

I haven't had any luck either.  

It does not look like anybody from Alchemex is looking into this issue. :(
I still have not provided a fix to my client and I posted into the forum last year.

What version of sage is this?

Mine is Sage 50 2018.  I've had this problem since November 2017.

RSS

The Sage Intelligence Blog

Like Sage Intelligence?

Follow @SageSupport

© 2018   Created by Sage Alchemex.   Powered by

Badges  |  Report an Issue  |  Terms of Service