modhorat
  • Male
  • KZN
  • South Africa
Share

modhorat's Groups

modhorat's Discussions

System Variables - Giving Error 7481 - Inconsistent Types
7 Replies

I'm getting an error in my connector when I try to use the '@MONTHSTART' system variable:I have the following SQL statement (Which works perfectly, giving the desired result):Select "vm-stock",…Continue

Tags: SystemVariables, SQL, Progress, Alchemex

Started this discussion. Last reply by Peter Scully Jun 15.

 

modhorat's Page

Latest Activity

Peter Scully replied to modhorat's discussion System Variables - Giving Error 7481 - Inconsistent Types
"Cool.  I was going to suggest checking the format of the system variable and making sure it aligns to the column format.  The other option would be to modify the column using something like a SQL CONVERT function.  Not sure if this…"
Jun 15
modhorat joined Les's group
Thumbnail

Sage Alchemex Recorded Webinars

Sage Alchemex runs weekly, topical webinars regarding the Sage Intelligence solution as well as products powered by Sage Alchemex. These webinars are recorded and you will find links to these videos in this group.See More
Jun 14
modhorat replied to modhorat's discussion System Variables - Giving Error 7481 - Inconsistent Types
"Don't stress, I think the error comes from the progress side, when the actual fields (columns) have some 'funny' incorrect data (example text in a numeric) This is what eventually worked: '@YEAR@' + '-' +…"
Jun 13
Peter Scully replied to modhorat's discussion System Variables - Giving Error 7481 - Inconsistent Types
"Hi modhorat. Just to let you know that I am looking at this and will get back to you shortly."
Jun 13
modhorat replied to modhorat's discussion System Variables - Giving Error 7481 - Inconsistent Types
"Alchemex standalone on a Progress Database"
Jun 12
Peter Scully replied to modhorat's discussion System Variables - Giving Error 7481 - Inconsistent Types
"What Sage business solution are you using?"
Jun 12
modhorat replied to modhorat's discussion System Variables - Giving Error 7481 - Inconsistent Types
"Now it gives me "Error in row""
Jun 12
Peter Scully replied to modhorat's discussion System Variables - Giving Error 7481 - Inconsistent Types
"Hi modhorat. Try placing @MONTHSTART@ in quotes, i.e. '@MONTHSTART@'. Let me know if this doesn't work."
Jun 12
modhorat posted a discussion

System Variables - Giving Error 7481 - Inconsistent Types

I'm getting an error in my connector when I try to use the '@MONTHSTART' system variable:I have the following SQL statement (Which works perfectly, giving the desired result):Select "vm-stock", "vm-make", "vm-comment", "vm-buydate", "vm-serial", "vm-cost", "vm-addcost" FROM "vm-inventory"Where ("vm-sold" = 0 OR ("vm-sold" = 1 AND "vm-buydate" > '2017-06-01'))Now to automate the report to run every month, I want to use the system variable @MONTHSTART@ in place of the static '2017-06-01'…See More
Jun 9
modhorat is now a member of The Sage Intelligence Community
May 22

Profile Information

How long have you been using the above solution?
3 months
Where did you hear about us?
Sage Intelligence website

Comment Wall

You need to be a member of The Sage Intelligence Community to add comments!

Join The Sage Intelligence Community

  • No comments yet!
 
 
 

The Sage Intelligence Blog

Like Sage Intelligence?

Follow @SageSupport

© 2017   Created by Sage Alchemex.   Powered by

Badges  |  Report an Issue  |  Terms of Service