Error when running the GL Details report using the current year. Whenever I run this report for the current fiscal year I get - ODBC SQL Server Driver][SQL Server]The conversion of a varchar data type to a datetime data type resulted in an out-of-range value. If I run it on a prior year it works fine.  Any ideas?

Views: 38

Replies to This Discussion

Do you mean the Standard General Ledger Transaction Detail 3-4 (AE-SQL)?

This report is version simple. 

Have you modified something in container?

I created my own report and used this container.  I added a couple of parameters, select fiscal year and select fiscal periods.

I just ran the canned report - no changes and it gave the same error when selecting fiscal 2019

Understand. Please double check your parameters. Or Expression (Excel type).
You may use as compare between Sage Date (yyyymmdd, String) with a Date value.

The parameters are fine - Select year - option is to select one fiscal year based on the fiscal years of history in the GL.  Select a starting period, select an ending period - 01 to 12.  What I can't understand is the report runs out if I select 2018 but errors if I select 2019?

You can email me your report to marius.yung@join-tec.net

Thanks for the offer Marius.  I found the problem, it was a corrupt record in the database - the date format was wrong.  Not sure how it happened but once I found the record, updated it with the correct format in SQL, then re-ran the report it worked fine.  Now I just have to do the same fix on the client's live data.

Thanks again.

RSS

The Sage Intelligence Blog

Like Sage Intelligence?

Follow @SageSupport

© 2019   Created by Sage Alchemex.   Powered by

Badges  |  Report an Issue  |  Terms of Service